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Killer Asteroids Lab #2:  Understanding the changing uncertainties of asteroid orbits 
 
GOALS:  The goal of this assignment is to understand the uncertainties inherent in the orbits and predicted 
positions of asteroids, and how these uncertainties change with time and with the inclusion of new data.  In 
the previous lab, you used early observational data for 2007 WD5 to determine its orbit and thousands of 
alternate possible orbits.  From these, you predicted the position of the asteroid on the date that it was 
observed by the Sloan Digital Sky Survey.  Today you will use this prediction to locate the asteroid in the 
images.  You will then add its positional information to the previous observational record and regenerate 
the possible orbits.  Comparison of the “before” and “after” cases will reveal how successive observations 
improve our knowledge of asteroid orbits. 
 
It is very important that you read this document carefully and follow all of its instructions.  Each step 
depends on those that precede it, and the data you produce now will be used in the weeks that follow.  
 
Remember to login to the computer using the following account, not your UAA active directory! 
 USERNAME: student 
 PASSWORD: labnet 
 
In Lab #1, you learned how to use four important tools that will aid you in your study of asteroid orbits and 
impact risks: 

• Measuring positions in astronomical images using ImageJ and the Polaris Plugin, 
• Determining orbits based on measured positions using Find_Orb, 
• Understanding how the seven orbital parameters specify an orbit around the Sun, and 
• Using Find_Orb to predict asteroid positions based on their orbital parameters. 

 
Specifically, you determined the best possible orbit for the asteroid 2007 WD5 based upon 25 positions 
from November 20th – December 19th, 2007.  In addition, you found over 3,000 alternate possible orbits that 
were also a reasonable fit to that data, which we will now refer to as clone orbits or virtual asteroids.  
These data should be stored in your group’s folder under “2007 WD5/Orbit Results/Epoch 1/Data Set A” 
with the following filenames: 

• mpc_fmt.txt – The best orbit solution, in machine-readable format. 
• elements.txt – The best orbit solution, in a more human-readable format. 
• mpcorb.dat – The 3,000+ clone orbits you generated, in the same format as mpc_fmt.txt. 

 
In our shorthand notation, the 1st epoch is the date of the SDSS observations (Nov 8, 2007) and the 2nd is 
the date of the close encounter with Mars (Jan 30, 2008).  Next week you will need to recalculate your 
orbits at Epoch 2 in order to get accurate estimates of the impact probabilities, but this week you will stick 
with Epoch 1. 
 
Before we make use of the 3 aforementioned files, let’s get your computer busy making the next set of 3.  
These will be based on the additional measurements that you are about to make of the asteroid’s position.  
So, first things first… 
 
 
 
Part I:  Adding in the SDSS imaging data 
 
In Question 8 of Lab #1, you predicted the position of 2007 WD5 for the night of Nov 8, 2007 (Epoch 1).  
You should have come up with the following coordinates:  
    RA: 2h 48m 40.927s 
    Dec: -00° 57’ 29.08” 
Your next step will be to download the images of this position from the Sloan Digital Sky Survey website.  
However, to do this you will first have to convert these coordinates from the usual XX:YY:ZZ format into 
decimal degrees.  To that end, please open the Excel spreadsheet file Coordinates-Converter.xls, which 
should be in your group’s folder within “Killer Asteroids Project/Student Data/”. 
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To convert to the new format, simply enter the RA and Dec values from above into the appropriate cells in 
the row labeled Position 1.  Once all seven of the white cells are filled, the two grey cells on the right will 
contain the RA and Dec in degrees.  Now if you select and copy those two cells, you’ll be able to paste 
them directly into the website that follows.  (If you’ll be completing your own asteroid orbit refinement 
project later in the semester, you will use a similar technique to download the necessary images.) 
 
Next point your browser to the SDSS Data Archive Server Coordinate List Submission Form:  

http://das.sdss.org/www/html/post_coords.html 
Paste your spreadsheet results into the form, put a comma between the two coordinate values, and then 
delete any other positions that had been entered by default.  Click “Submit Request”, and you will be 
presented with a long list of all the images of that position that have been taken by the survey, going all the 
way back to 1998.  Click the link next to Run #7142, which was imaged on the same date and time as our 
prediction.  The images you’ll want to download are the Corrected Frames files for the g, r, & i filters.  
Right-click each file in turn, saving each one to your group’s “2007 WD5/Images/” folder.  Then, press 
your browser’s “back” button and click the link for Run #2700.  Again, download the Corrected Frames 
files labeled g, r, & i.  These will serve as reference images, which were taken of the same position but at a 
very different date and time.  They are guaranteed not to contain the asteroid, so they will help you to 
correctly identify it in the images that do contain it. 
 
You should now have the following files saved in your “2007 WD5/Images/” folder: 

fpC-002700-g1-0147.fit.gz  fpC-007142-g1-0183.fit.gz 
fpC-002700-i1-0147.fit.gz  fpC-007142-i1-0183.fit.gz 
fpC-002700-r1-0147.fit.gz  fpC-007142-r1-0183.fit.gz 

These images have been g-zipped, and they will need to be decompressed with a program like 7-Zip  (or 
WinZip) before they can be opened with ImageJ.  If you select all of them at once, you should then be able 
to right-click them and select 7-Zip > Extract Here.   
 
Now you can finally get your hands on the images!  Run the image analysis program ImageJ by double-
clicking its icon on the desktop (or by finding it in the Start Menu).  This will open the ImageJ toolbar, 
which has the traditional Windows pull-down menus along the top.  Open the series of images using “File > 
Import > Image Sequence…” and select any one of the 6 images listed above.  When the “Sequence 
Options” window pops up, just click OK.  The images will appear black and almost featureless due to poor 
contrast settings, but the Polaris Plugin will take care of this. 
 
Select “Plugins > Polaris > Polaris Plugin Options” and make sure the settings are as follows. 
 Checked:  Invert, Align, Hyper-stack, & Auto-contrast images on load 
 Unchecked:  Seek brightest pixel & Write to log file 
 Output Format:  RWO 
 MPC Designation: K07W05D (Those are zeros.  All caps, no spaces.) 
 RWO Designation: 2007WD5 (Those are zeros.  All caps, no spaces.) 
 Observatory Code: 645 
 Checked:  Astrometric output only 
Capitalization and spacing do matter!  When you click “Apply,” it’s OK if these preferences cannot be 
saved for future use, but rest assured that they will be used presently. 
 
Start the plugin using “Plugins > Polaris > Polaris Plugin.”  The screen will flicker a few times as the 
images are inverted and aligned, and reasonable contrast settings are found.  In fact, the images come out a 
bit dark, so adjust the contrast of the images with “Image > Adjust > Brightness/Contrast…”.  Click 1-2 
times on the second slider’s right-arrow to brighten up the first image, and repeat for the remaining images. 
 
The image sequence can now be animated using the backslash ( \ ) keyboard shortcut.  If they flip by too 
fast, the speed can be adjusted with “Image > Stacks > Animation Options…”.  The exposure times and the 
delays between the images are identical to the asteroid we called Keanu that you examined in Lab #1, but 
2007 WD5 is fainter and moving slower.  However, it is still moving fairly quickly, so it may stand out in 
the animation. Can you see it?  It should be near the predicted position listed at the beginning of Part I.  
You can locate this position within ImageJ by watching the RA and DEC coordinates change as you move 
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the mouse over the image.  You may find useful the Point Selections tool, which lets you lay a small set of 
cross-hairs on the image with a click of the mouse.  Once you have found the predicted position (to the 
nearest pixel), jot down its X and Y pixel coordinates so you can find it again quickly later on.  Use the 
ImageJ magnifying glass tool to zoom in on this position.  Can you see the asteroid now?  Remember that it 
should only be in the final three images of the animation, and not in the first three.  When you have found 
it, zoom in so that all 3 asteroid streaks as well as the predicted position all fit nicely in the image window.  
Finally, stop the animation by once again hitting the backslash key ( \ ). 
 
 Warning:  The streaks in the 3 images should not overlap each other!  The asteroid is just a dot of light, 
which appears as a streak because it moved while the image was being taken.  When the shutter opens for 
the next exposure, the asteroid picks up where it left off.  So together, the streaks should look like a dashed 
line with uneven spaces in between.  If your streak doesn’t move from image to image, you’ve probably 
found yourself a galaxy instead of an asteroid.  You should also be able to distinguish between them by 
consulting your reference images:  Your asteroid should not be present in them, while a galaxy should be 
at the same location in all of your images. 
 

1. Use the scroll bar at the bottom of the image window to switch to the final image of the 
sequence.  (Scroll all the way to the right).  How close is the predicted position of the 
asteroid to its actual position in the image?  (Your answer can be qualitative at this point.  
Describe it in words, not numbers!) 

 
Now you will measure the positions as you did in Lab #1.  You may want to switch to either the Scrolling 
(hand icon) or Rectangular Selections tools, to make your clicks more accurate and to avoid unwanted 
zooming.  Make sure that the image window is selected, and move the mouse to the center of the asteroid 
streak.  It is important that you point accurately at the midpoint of the streak, because the position of the 
mouse is the one that will be measured.  When you are happy, press the space bar to record this location.  
The position will be marked on the image, and the measurement data will appear in the “Measured 
Magnitudes” box near the bottom of the data panel.  (You may have to scroll to the right or detach and 
widen the panel to see the complete RA and Dec.)  Repeat for each of the last three images.  If you make a 
mistake, you can remove the last measurement by clicking the “Clear Last Measured” button, or you can 
clear all of them with the “Clear All” button.  When you’re finished, there should be exactly three entries in 
the “Measured Magnitudes” box. 
 

2. From the “Measured Magnitudes” box, what is the position you measured (RA and Dec) for 
the asteroid streak in the final image of the sequence?  (Scroll all the way to the right.)  

 
In ImageJ, underneath the “Measured Magnitudes” box, click the “Copy Results” button to stash the results 
on the clipboard.  Now navigate to your group’s folder and open up the following file in a text viewer (by 
double-clicking): 
 2007 WD5/Astrometry/2007 WD5 as of 2007-Dec-28.rwo.txt 
This filename references Dec 28th because this was the date that NASA originally acknowledged these new 
measurements with an updated press release.  Paste your new results between the two lines that say “Add 
new data here” and “End of record.”  If the designations in the first column don’t match the others in the 
file (including capitalization), you will need to change your new lines to match.  Save your changes to the 
file, keeping the filename the same.   
 
You will now repeat the orbit determination for 2007 WD5 based on this new data.  In the “Killer Asteroids 
Project” folder, double-click the “Find_Orb Shortcut” icon, which looks like a bunch of dots orbiting a 
yellow sun.  Then click the “Open…” button and double-click on the astrometry file you just saved. 
 
First, double-check that your newly-measured positions are shown here.  There should be 3 new lines at 
the top of the data window, from observatory code 645 on November 8th, 2007.  If not, then you need to 
do some troubleshooting:  Are you sure you opened the correct file?  Do you see multiple designations in 
the box directly below the “Open…” button in Find_Orb?  If that’s the case, go back and re-read the 
warning a few paragraphs ago regarding designation-matching (including capitalization).  You will need 
to resolve these issues before you continue! 
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Next, check all of the boxes in the Perturbers section at the top of the window, and change the Epoch 
value to “2007 11 08”.  Also, you’ll need to supply Find_Orb with guesses for the asteroid’s distance from 
the Earth on the first and last dates of observation.  Try R1 = 0.1 AU and R2 = 0.3 AU, which were 
roughly the values found in Lab #1.  Then, locate the two inactive observations marked with X’s in the 
astrometry window, and use the “Toggle Obs” button to reactivate them.  Finally, click the Auto-Solve 
button.  Notice that the RMS error drops to about 0.7”, which indicates that this orbit is a good fit to the 
observations. 
 
Warning:  At this point, the last line of the “Orbital Elements” box should read:  “From 28 observations 
2007 Nov. 8-Dec. 19.”  This reflects the addition of your 3 new observations from Nov 8th.  In addition, all 
of the Perturbers should be checked, and the Epoch should be set to the value indicated above.  If any of 
these are not the case, your orbit will be incorrect.  Go back and try again! 
 
Next, you need to grab the output files from the Find_Orb folder before they get overwritten!  Drag the 
elements and mpc_fmt text files from there to your group’s “2007 WD5/Orbit Results/Epoch 1/Data Set B” 
folder.  While you have the Find_Orb folder open, make sure to delete the file there called mpcorb.dat, if it 
exists.  You are about to ask the program to put thousands of lines of orbital data into that file, but if the file 
already exists they will be appended at the end, and that will mean more work for you. 
 
Go back to Find_Orb and click on the Monte Carlo button, which will quickly start counting the number 
of virtual asteroid orbits that are being generated.  Take note of the current time, and remember to come 
back to collect its output in about 25 minutes, when that number gets above 3,000.  At that point, you will 
click the Monte Carlo button (now labeled with the running orbit-count) again to stop the process.  You 
will then drag the mpcorb.dat file from the Find_Orb folder into your “2007 WD5/Orbit Results/Epoch 1/ 
Data Set B” folder. 
 

 
 
 
 
Part II:  Using Starry Night to understand the clone orbits 
 
Last time, you generated files named mpc_fmt.txt and mpcorb.dat, which should reside in your group’s 
folder under “2007 WD5/Orbit Results/Epoch 1/Data Set A”.  These files contain the orbital parameters for 
the best-guess orbit of the asteroid and all of the clones, respectively.  Unfortunately, they are in a format 
that we cannot use directly.  First we must convert them to what is called ASTORB-format, in order to be 
able to plug them directly into Starry Night.  In the same folder, you should find an empty text file named 
Asteroids.  Once you have converted these data to the new format, you will paste them into this file.  
(Instructions follow.) 
 
Using a web browser, open the following page:  

http://puck.uaa.alaska.edu/mpcorb2astorb/ 
Open the file mpc_fmt.txt in a text viewer (by double-clicking), copy its contents, and paste them into the 
top text box on the webpage.  (Use control-A to select all contents of a file, control-C to copy the selection, 
and control-V to paste.)  Repeat these steps for the file mpcorb.dat, making sure the contents are pasted in 
the top text box, but below what you’ve already pasted.  (This is just a text file with a funny extension, so 
you can use the same text viewer as before to open it.)  Look back over what you’ve pasted, and make 
certain that all of the columns line up with each other!  A common mistake is to forget to copy a space at 
the beginning of a line, which would knock off the alignment of that line.  Then, from the pull-down menu 
at the middle of the page, select “Boost brightness by 5 mags” to make the asteroids appear brighter in 
Starry Night.  Finally, click the Convert button, and the bottom text box will fill up with the ASTORB-
format data.  Copy the entire contents of this bottom text box, paste them into the file Asteroids mentioned 
above, and make sure to save the file!  (If your mpcorb file contains significantly more than 3,000 orbits 

While you’re waiting, please continue with the rest of the lab. 
You won’t need these Monte Carlo results until Part III. 
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and this conversion seems to take forever, you can trim it down to just over 3,000 lines and you should see 
better results.) 
 
Now you are ready to add these data to Starry Night.  Unfortunately, you can only add a batch of new 
asteroids to its database by restarting the program, so make sure it is closed before you proceed.  In the 
“Killer Asteroids Project” folder on your desktop, open the “Starry Night Sky Data” shortcut.  Copy your 
Asteroids file from your group’s folders, and paste it into this Sky Data folder.  (Replacing an existing copy 
is OK.)  Do not change its name, and don’t put it into a subfolder!  Starry Night is very particular about the 
name and location of the file from which it loads its asteroids.  Copying-and-pasting is important, because 
you will want to keep a copy of the file in your group’s folders for future reference. 
 
Open “Starry Night Pro Plus 6” from the desktop, but do not let Starry Night update its data files at startup.  
Confirm that your asteroids are loaded by opening the Find tab at the left edge of the screen, expanding the  
Asteroids entry, then clicking repeatedly on gray bar at the top of the Name column to change the sort 
order (alphabetical, then reverse alphabetical). 
 

3. After sorting alphabetically, what are the names of the first 2 asteroids on this list?  The 
last 2?  (They will probably look something like “K07W05D [123]” or “2007 WD5”.)  Do 
these make sense, given that you expect there to be 3,000 clone orbits loaded? 

 
Next, you’ll need to set your viewing location.  Select “File > Open…” within Starry Night, navigate 
to“Starry Night Scenarios” in the “Killer Asteroids Project” folder, and open the file labeled “from SDSS 
telescope.”  You will need to change Starry Night’s  time and date to “1:53:48am November 8, 2007 
AD.” This is the exact moment (in Mountain Standard Time) that 2007 WD5 was imaged by the Sloan 
Digital Sky Survey, which we are calling Epoch 1.   
 
Note:  You can change most parts of the time and date (hours, minutes, seconds, month, day, year) by 
clicking on the entry and entering the new value from the keyboard.  To change the month, you enter its 
numerical value from 1 – 12. 
 
You should also confirm that your Viewing Location is now set for either “SDSS Telescope”.  If any of 
the time, date, or location are wrong, your results will be wrong and your grade will suffer for it!  But if 
they’re all correct, the field of view should contain the asteroid’s predicted position (marked in red), 
located near the center of a swarm of greenish-white virtual asteroids.  Center on the asteroid by right-
clicking it and choosing “Centre”, then zoom in using the “+/–” near the upper right corner. 
 
For Questions 4-8, please enter your answers in Table 1, provided on the last page of this document.  
Tear that page off and include it with your work when you hand it in. 
 

4. Choose the Angular Separation tool (to the left of the Time & Date display), then drag your 
mouse from one end of the swarm to the other.  (If there are a few “stray” points on either 
end of the swarm, you can ignore them.)  The angle between those two points will be given in 
degrees, arcminutes, and arcseconds (° ’ ”).  Divide this by 2 and you have a measure of the 
uncertainty of the predicted position.  (This math can get tricky, but it may help to think in 
terms of time.  If your angle measurement is 3’ 10”, think of that as a time of 3min 10sec.  
Half of that would be 1min 30sec + 5 sec = 1min 35sec.  Changing back to the correct 
angular units, your answer would be 1’ 35”.) 

 
5. Right-click on the asteroid and select “Centre” to make Starry Night track it as it moves.  

Switch the Time Flow Rate to 1 days, and run time backward to November 1st.  What is the 
value of the uncertainty on this date?  (Remember to “÷2”.)  How many times bigger was the 
swarm on this date, just one week earlier than your previous measurement?  (Write this factor 
in the margin next to Table 1.) 

 
6. Now run time forward.  On what date does the uncertainty ( “÷2” ) first reach 5” (arcseconds) 

or less?  What is the value of the uncertainty on this date? 
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7. Continue to run time forward.  What is the first date when the uncertainty ( “÷2” ) once again 

reaches 5” (arcseconds) or more?   
 

8. Continue to run time forward to January 30, 2008, the date of the asteroid’s close approach 
with Mars.  What is the value of the uncertainty ( “÷2” ) for this date?  (January 30, 2008.) 

 
Your answers to Questions 6 and 7 define a range of dates when the uncertainty in the predicted position 
for 2007 WD5 is particularly small.  Compare this with the range of dates for which we have observations 
of the asteroid (see Question 4 of Lab #1, or the caption for Table 1).  These two sets of dates seem pretty 
similar, don’t they? 
 
 

 

 
Figure 1 – A sketch of asteroid observations and resulting orbits. 

 
 
 
Please refer to Figure 1 above to help you answer Questions 9 and 10. 
 

9. Explain why you think the uncertainty in the predicted position is so small during the range of 
dates for which we have real observations of the asteroid.  (Give a reason for this behavior.) 

 
10. Explain why you think the uncertainty grows so much larger when you look beyond the range 

of dates for which we have real observations.  (Give a reason for this behavior.) 
 
 
 
 
Part III:  Understanding the NEW clone orbits 
 
It is now time to make use of the new orbits you generated in Part I above, which are based on the 
measurements you made of the position of 2007 WD5.  If you have not yet stopped the Monte Carlo process 
in Find_Orb or placed the resulting mpcorb.dat file in your group’s folder, please see the instructions at the 
end of Part I. 
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You will now repeat the procedure from the beginning of Part II above.  Convert the contents of  mpc_fmt 
and mpcorb from “2007 WD5/Orbit Results/Epoch 1/ Data Set B” to the new format, and paste the results 
into the empty Asteroids text file.  Next, copy-and-paste this file into the “Starry Night Sky Data” folder 
(probably overwriting your previous version, which is fine).  Finally, close and restart Starry Night. 
 
Select “File > Open…” within Starry Night and open the file labeled “from SDSS telescope” as before.  
Change the time and date to “1:53:48am November 8, 2007 AD”, and confirm that your location is one 
of the observatories listed previously.  You should notice that the uncertainty region has shrunk 
considerably.   
 

11. Answer Questions 4-8 again based on these new data.  Please enter your answers in 
Table 2, where they are labeled Questions 11.4-11.8.  

 
12. Have your answers to Questions 9-10 changed based on your newfound experience?  If so, go 

back and change them. 
 

13. Compare your results in Table 1 with those in Table 2.  What have you accomplished by 
adding the SDSS data into the orbit solutions, regarding your ability to predict the asteroid’s 
position in the sky? 

 
14. An astronomer asks for your help to find 2007 WD5 in images taken on Nov 1st, 2007.  She 

does not have access to your images from Nov 8th, but you can tell her about your results. 
Without your help, the uncertainty in her predicted position would be given by Table 1.  By 
helping her, you change her uncertainty to that of Table 2.  Have you made her job easier?  
If so, how much so?  (Support your answer with numerical values from Tables 1 & 2.) 

 
15. In your own words, explain what the swarm of virtual asteroids on your screen represents.  

(Look back at the description of the Monte Carlo method from Lab #1, if necessary.) 
 
 
 
 
 
Part IV:  Cleaning Up After Ourselves 
 
As has been mentioned previously, you may be sharing your computer with students in another section of 
this class.  To avoid hassle and confusion for them, please do the following: 
 

• In the “Starry Night Sky Data” folder, locate your Asteroids text file. Delete it, but first make sure 
that you saved a copy in your group’s folder!) 
 

• Make sure that you have not left a file named mpcorb in the Find_Orb folder.  Delete it if it exists, 
but first make sure that you saved a copy in your group’s folder! 

 
• Make sure all of the files you have saved are in your own group’s folder within 

“Killer Asteroids Project/Student Data/” 
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Appendix:  Organizing your data 
 

Table 1:  Results based on observations from Nov. 20th – Dec. 19th, 2007 

Date Uncertainty Notes 

Nov. 1st, 2007  Question 5 

Nov. 8th, 2007  Question 4 

First below 5”: 
_____ ____ 200__  Question 6 

First above 5”: 
_____ ____ 200__  Question 7 

Jan. 30th, 2008  Question 8 

 
 
 

Table 2:  Results based on observations from Nov. 8th – Dec. 19th, 2007 

Date Uncertainty Notes 

Nov. 1st, 2007  Question 11.5 

First below 5”: 
_____ ____ 200__  Question 11.6 

Nov. 8th, 2007  Question 11.4 

First above 5”: 
_____ ____ 200__  Question 11.7 

Jan. 30th, 2008  Question 11.8 

 
 


