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Killer Asteroids Lab #1: Learning how to measure positions and determine orbits 
 
GOALS:  The goal of this assignment is to learn how to measure asteroid positions in digital images, and 
how to use these positions to determine the orbit of the asteroid.  You will also learn what parameters are 
necessary to specify an orbit, and the effect of each on the shape and orientation of the orbit.  Finally, you 
will learn how to generate alternate possible orbits for a given asteroid. 
 
You will use these skills over the coming weeks to study the asteroid 2007 WD5, which narrowly missed 
hitting Mars on January 30, 2008.  In particular, you will estimate the probability of impact based upon 
what was known about this object’s orbit at various points between its discovery and the date of the 
possible impact.  You should then understand why every “impact scare” to date has followed the same 
pattern:  Odds first go up, but then they fall quickly to near zero.  You’ll also get the “bigger picture”:  
Science involves uncertainty, and it takes time and hard work to get good results.  
 
 
Part I:  Measuring Asteroid Positions with ImageJ 
 
The first goal of this assignment is to teach you how to measure the positions of celestial objects in digital 
images.  In particular, you will be measuring the position of an asteroid as it streaks through a field of 
background stars.  (The measurement of positions of celestial objects is known as astrometry.)  Of course, 
since the asteroid is moving, it is also important to accurately note the time at which it was found at a 
particular position.  Tracking an asteroid’s motion across the sky allows us to estimate its orbital path 
around the Sun, and more data provides a better estimate.  This, in turn, allows us to predict the future 
position of the asteroid, and to determine whether or not it is likely to hit Earth or Mars. 
 
It is very important that you read this document carefully and follow all of its instructions.  Each step 
depends on those that precede it, and the data you produce now will be used in the weeks that follow.  
 
First, it is important that you login to your computer using the following information. 
 USERNAME: student 
 PASSWORD: labnet 
Do not login to your UAA active directory!  The software for this project will not work correctly if you do.    
 
Locate the “Killer Asteroids Project” folder on your computer’s Desktop; this will be your “command 
center” for this sequence of asteroid labs.  This project will involve a lot of electronic data, and it’s 
important that you keep it organized.  In particular, you may be sharing your computer with students in 
another lab section!  Double-click on the “Student Data” folder, then create a new copy of the “GROUP 
TEMPLATE” folder you find there.  (First copy it, then paste a new copy alongside it.)  Finally, rename 
this new folder with some clever name to represent your group.  This will contain all of our group’s data, 
images, and results over the next three labs. 
 
Let’s begin by examining three images of an unidentified asteroid, taken by the 2.5-meter telescope of the 
Sloan Digital Sky Survey (SDSS) on February 12, 2000.  This is a relatively fast-moving NEO (Near-Earth 
Object), so let’s call it Keanu.  Run the image analysis program ImageJ by clicking on its icon on the 
desktop, or by finding it in the Start menu.  This will open the ImageJ toolbar, which has the traditional 
Windows pull-down menus along the top.  Open the series of images using “File > Import > Image 
Sequence…”, navigate to your group’s folder, and select the file: 
  Keanu/Images/fpC-001140-g4-0122.fit 
When the “Sequence Options” window pops up, just click OK.  The images will appear black and almost 
featureless due to poor contrast settings, but this will be taken care of shortly. 
 
The software that will allow you to examine astronomical images is the Polaris Plugin, which requires 
some setup before you begin.  Select “Plugins > Polaris > Polaris Plugin Options” and make sure the 
settings are as follows. 
 Checked:  Invert, Align, Hyper-stack, & Auto-contrast images on load 
 Unchecked:  Seek brightest pixel & Write to log file 



 2 

 Output Format:  RWO 
 MPC Designation: UNK0001 
 RWO Designation: UNK0001 
 Observatory Code: 645 
 Checked:  Astrometric output only 
When you click “Apply,” it’s OK if these preferences cannot be saved for future use, but rest assured that 
they will be used presently. 
 
Start the plugin using “Plugins > Polaris > Polaris Plugin.”  The screen will flicker a few times as the 
images are inverted and aligned, and reasonable contrast settings are found.  Move between the three 
images in the sequence by using the scroll bar at the bottom of the image.  To adjust the brightness and 
contrast (B&C) of each image manually, use “Image > Adjust > Brightness/Contrast…”.  For instance, you 
may find that the last image in the sequence is darker than the rest.  You can brighten it up by clicking a 
handful of times on the right arrow of the Maximum slider (2nd from the top).  Changes will take effect 
immediately, so there’s no need to click Apply.  If you’d like to reset the B&C settings, you can always 
restart the plugin by reselecting it from the Plugins menu. 
 
Animate these three images with “Image > Stacks > Start Animation,” or you can toggle the animation 
on/off using the backslash ( \ ) keyboard shortcut.  If they flip by too fast, the speed can be adjusted with 
the “Animation Options…” selection in that same pulldown menu.  The asteroid should be immediately 
obvious, streaking across the image from left to right.  (In reality it streaked from right to left, because 
ImageJ opens the images in alphabetical order, which happens to be reverse chronological order for these 
SDSS filenames.)  Note that the asteroid itself is not pencil-shaped!  In a much shorter exposure it would 
look like a point of light, just like the stars do.  However, each of these images had an exposure time of 
roughly 54 seconds.  The shutter was left open to collect light for that amount of time, during which the 
asteroid moved the length of the streak.  (Imagine taking a long exposure of a racetrack as a single car 
speeds by.)  Use the ImageJ magnifying glass tool to zoom in (left-click) on the asteroid, so that all three 
streaks are visible together on the screen.  (Right-click if you need to zoom out.)  At this point, you may 
stop the animation by hitting the “ \ ” key. 
 
The panel on the right displays the celestial coordinates (RA = Right Ascension, Dec = Declination) of 
each pixel as you move the mouse over the image.  You can think of these coordinates as extensions of the 
longitude and latitude coordinates we use here on Earth.  It may help if you imagine that we are at the 
center of a giant celestial sphere, with all of the stars and galaxies of the night sky painted on the inside.  
That sphere appears to rotate around the north celestial pole (Declination = +90°), which is directly above 
the Earth’s north pole.  It also has a celestial equator (Declination = 0°), which is directly above the Earth’s 
equator.  Right Ascension is measured around this equator (east/west), while Declination is measured 
perpendicular to this equator (north/south).  (In other words, Right Ascension is like Earth Longitude, 
and Declination is like Earth Latitude.)   
 
Right Ascension and Declination are each usually written as three numbers separated by colons, such as 
12:34:56.  If this looks like a time to you, it should!  The celestial sphere appears to revolve around the 
Earth once every 24 hours, so the night sky can be used as a rudimentary clock.  For this reason, Right 
Ascension is traditionally measured in hours, where 24 hours make up a full 360° circle.  Each hour is then 
subdivided into 60 minutes, and each minute into 60 seconds, just as with time.  The format for writing RA 
is thus hours : minutes : seconds.  Declination is measured in the usual degrees, which are similarly divided 
into 60 arcminutes ( ’ ), and those into 60 arcseconds ( ” ).  The format for writing Declination is thus 
degrees : arcminutes : arcseconds.  Note that 1 hour of RA = 15°, 1 min of RA = 15’, & 1 sec of RA = 15”. 
 
You will now make your first measurement of Keanu’s position in an image.  First, you may want to switch 
to either the Scrolling (hand icon) or Rectangular Selections tools.  Next, make sure that the image window 
is selected, and move the mouse to the center of the asteroid streak.  It is important that you point 
accurately at the midpoint of the streak, because the position of the mouse is the one that will be measured.  
When you are happy, press the space bar to record this location.  It will be marked on the image, and the 
measurement data will appear in the “Measured Magnitudes” box near the bottom of the data panel.  (You 
may have to scroll to the right or detach and widen the panel to see the complete RA and Dec.)  Repeat for 
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each of the three images.  If you make a mistake, you can remove the last measurement by clicking the 
“Clear Last Measured” button, or you can clear all of them with the “Clear All” button. 
 
When you’re finished, there should be exactly three entries in the “Measured Magnitudes” box.  Click the 
“Copy Results” button to stash the results on the clipboard.  In your group’s folder, locate the file: 
  Keanu/Astrometry/Keanu Astrometry.rwo.txt 
Open the file, paste in the results below the 2 lines of column headers, and save the file.  You will see 3 
long lines of data in RWO format, which are compatible with the data downloadable from the Asteroid 
Dynamics (AstDys) and Near Earth Object Dynamics (NeoDys) websites.  If you’re interested, you can 
visit those sites at: 

AstDys –  http://hamilton.dm.unipi.it/cgi-bin/astdys/astibo 
NeoDys –  http://newton.dm.unipi.it/cgi-bin/neodys/neoibo 

(You do not need to visit either of these sites to complete this project.) 
 
Take a look at the following sample of data in this format, along with column headers.  Each line is too 
long to be printed here on a single line, so this sample will be split up into four parts.   
 

! Object   Obser ============= Date =============  
! Design   K T N YYYY MM DD.dddddddddd   Accuracy  
 2007WD5   O C   2007 11 20.32652       1.000E-05  
 
================== Right Ascension =================  
HH MM SS.sss  Accuracy      RMS  F     Bias    Resid  
04 13 56.060  1.500E-01    1.000 F    0.000    0.027  
 
 ================= Declination =====================  
sDD MM SS.ss  Accuracy      RMS  F     Bias    Resid  
+17 21 43.00  1.000E-01    1.000 F    0.000   -0.694  
 
==== Magnitude ==== Obs  Residual SEL 
Val  B   RMS  Resid Cod       Chi A M 
20.0 V  0.70  -0.26 G96      0.71 1 1 

 
 
There’s a lot of information here that you won’t need to understand, but the parts you should be aware of 
have been italicized and underlined.  Let’s go through them one by one. 
 

• The Object Designation is the asteroid’s “name.”  In the above sample, the name is 2007 WD5.  
This value is specified to the Polaris Plugin by setting the “RWO Designation” in the Plugin 
Options.  (You do not need to set this option now, but whenever you do, it is important that you 
use the correct capitalization and spacing!  Even slightly different designations are considered to 
be different asteroids by the software you will be using.) 

 
• The Observation Date is given in an odd decimal-days format that bears explaining.  In this 

sample, the first two parts are what you would expect:  2007 is the year, and 11 is the month.  
What the third part tells you is that 20.32652 decimal days have elapsed since the beginning of the 
month, taking into account the exact time of day that the observation was made.  You can figure 
out what time of day that was by multiplying the decimal part by 24 hours:  0.32652 days × 
24 hrs/day = 7.83648 hrs, or roughly 7:50am.  The Earth is round, so you also need to know 
what time zone this is in.  The convention in astronomy is to use Universal Time (UT), which is 
effectively the same as Greenwich Mean Time (GMT) of Greenwich, England. 

 
• The Right Ascension coordinate is displayed without its customary colons.  Putting them back in, 

we have RA = 04:13:56.06 (hr : min : sec).  You might also see this written as 4h 13m 56.06s. 
 

• The Declination coordinate is also displayed without colons.  Putting them back in, we have 
Dec = +17:21:43.0 (deg : arcmin : arcsec).  You might also see this written as +17° 21’ 43.0”. 

 
• The Observatory Code (“Obs Cod”) is a 3-character code that tells you which observatory made 

these observations.  This value is specified to the Polaris Plugin by setting it in the Plugin Options.  
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(You do not need to set this value now.)  In this example it is G96, the code for the Mt Lemmon 
Survey observatory north of Tucson, AZ.  If you’re interested, a list of observatory codes is at:  

http://cfa-www.harvard.edu/iau/lists/ObsCodesF.html 
(You do not need to visit this site to complete this project.) 

 
• Note that the plugin will always leave the Residual and Chi values blank.  Your results will also 

lack any of the Magnitude information, because you have chosen the “Astrometry Only” option. 
 

1. From your own measurements in Keanu Astrometry.rwo.txt, identify which line of data 
represents the first observation made on that day.  What was the full decimal date (year,   
name of month, and decimal days)?  What were the RA and Dec?  

 
2. At roughly what time of day was this image of Keanu taken?  Give your answer in both 

Universal Time (UT) and Mountain Standard Time (MST), to the nearest 10-15 minutes.  
(MST = UT - 7 hours.)  (Start by converting the decimal part of the days into hours, as 
outlined above.  Next, estimate the minutes from the decimal part of the hours.  Together, the 
hours and minutes give you a time in UT on a 24-hour clock.  Finally, convert to MST.)   
Also, given that the SDSS telescope keeps Mountain Standard Time in February, would 
it have been dark at the telescope at this time? 

 
3. If a celestial globe is available in the lab, use it to locate the (RA, Dec) coordinates from your 

answer to Question #1.  In which constellation are these coordinates located?  (If you find 
the globe confusing, please go back and re-read the coordinate descriptions on page 2.  Also, 
note that both a second and an arcsecond are smaller than 1/2,000th of an inch on a 12-inch 
globe, so you can ignore these parts of the RA and Dec for this question.) 

 
You are finished with ImageJ for today, so it can now be closed. 
 
 
 
 
Part II:  Finding Orbits with Find_Orb 
 
You will now begin your investigation of the asteroid 2007 WD5, which gained notoriety over Christmas 
break 2007 because it had the potential to hit Mars in late January with the energy of a nuclear blast.  To 
see the astrometric record for this object as of 2007 Dec 21, go to your group’s folder and open the file: 
 2007 WD5/Astrometry/2007 WD5 as of 2007-Dec-21.rwo.txt 
The format of the file is the same as that described above, so you should already be an expert at reading it. 
 

4.  What were the first and last dates on which this asteroid was observed?  How many total 
observations (measured positions) were there?  How many different observatories 
(observatory codes) were involved? 

 
You will now use this astrometric record to make a “best guess” at the orbit for this asteroid, based on the 
available data.  In the “Killer Asteroids Project” folder, double-click the “Find_Orb Shortcut” icon, which 
looks like a bunch of dots orbiting a yellow sun.  Then click the “Open…” button, navigate back to your 
group’s folder, and open the astrometry file mentioned above, in the first paragraph of Part II.   
 
Warning:  Every time you use the “Open…” button, most of Find_Orb’s checkboxes and text boxes will 
return to their default values for that asteroid.  So if you have to re-open the astrometry file, you should 
plan to re-enter all of your settings as well. 
 
First, take a moment to learn your way around the Find_Orb window.  At the top are check-boxes and text 
inputs that control how the orbits will be calculated.  A box in the middle labeled “Orbital Elements” 
displays the parameters that define the current guess at the orbit.  Near the bottom is a large text box with a 
scroll bar, which displays a summary of the contents of the astrometry file that is currently open.  If one or 
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more of the observations in this box is selected, then the space at the bottom of the window will display 
further information on that particular observation(s). 
 
An important point to notice about the initial orbit displayed by Find_Orb is just how horrible it is as a fit 
to the data.  You can see this by first examining the astrometry box that has the scroll-bar.  Each line shows 
first the date, observatory code, RA, and Dec of the observation.  The final two columns then give the 
differences in RA and Dec between the position predicted by the current orbital solution and the actual 
observed position.  These residuals or errors will normally be given in arcseconds, but when they get too 
large, a “d” will indicate that they have switched over to degrees.  A good residual for each observation 
would be less than about 1 arcsecond, so you can see how bad this current solution is!  A good way to 
summarize the quality of a particular solution is to calculate some sort of statistical average of all of these 
residuals.  Find_Orb does this in the form of the root-mean-square (RMS) error, shown directly above the 
astrometry box’s scroll-bar.  A good value would once again be less than 1 arcsecond, but in this case it is 
more than 3,000 arcseconds, or almost a whole degree!  You can do much, much better. 
 
Click on the “Settings” button at the right-center of the Find_Orb window.  Make sure that the 
“Heliocentric orbits only” option is checked, and that the “Element precision” is set to 7, then click OK.  
This will force your solutions to orbit the Sun instead of the Earth, Moon, or Mars.  Next, check all of the 
boxes in the Perturbers section at the top of the window.  This tells Find_Orb to take into account the 
gravity of all of these planets, asteroids, and moons as it calculates the orbit of your asteroid.  Finally, ask 
for the orbit for a specific date by changing the Epoch value to “2007 11 08”.  The significance of this 
particular date will become clear in Lab #2.  Now click the Auto-Solve button once or twice. 
 
Ordinarily you’d be done at this point, but as you can see, the RMS error value isn’t getting any better.  In 
fact, it has gotten worse!  That’s because these observations were made over a fairly short period of time, 
when 2007 WD5 was making a particularly close approach to the Earth.  Fortunately, there’s something else 
we can try.  The astrometry file also includes measurements of the brightness of the asteroid, which 
astronomers measure in terms of magnitudes.  This particular asteroid got fainter by about 2 magnitudes 
over the course of these observations.  From this information, it’s possible to estimate that on the last of 
these dates, the asteroid was about 3 times farther away from the Earth than on the first date.  So suppose 
we take a guess and say that this distance grew from a mere 0.05 astronomical units (AU) to a slightly more 
comfortable 0.15 AU.  (The Earth is 1 AU from the Sun.)  Plug these values into Find_Orb as follows: 
 R1:  0.05 AU 
 R2:  0.15 AU 
Once again click the Auto-Solve button.  (Notice that the values of R1 and R2 get revised based on the 
specifics of the new best-guess orbit.  While our specific guesses were not correct, the ratio of 3 between 
them ends up being pretty accurate.)  Confirm that your RMS error value is now less than 1 arcsecond.  
(If it isn’t, then you missed something, and you need to go back and fix it!) 
 
Congratulations, you’ve found an excellent guess at the asteroid’s orbit!  (Jot down the RMS error, which 
will be part of your answer to Question 5.)  However, in this case we are going for historical accuracy, so a 
few more steps are required.  Scroll down in the astrometry window until you find the two observations 
with an X between the date and the observatory code.  These two observations are not currently being used 
in the orbit solution, but they were being used in the predictions back in mid-December 2007.  As more 
observations have been made, it has become clear that something went wrong with these two.  To make 
them active, select these two rows and click the Toggle Obs button.  Now click Auto-Solve again, and you 
can see that the RMS error has gotten a bit larger, but not too bad.  Again, we are going for historical 
accuracy here. 
 
Warning:  At this point, the last line of the “Orbital Elements” box should read:  “From 25 observations 
2007 Nov. 20-Dec. 19.”  These should match your answers to Question 4 above.  In addition, all of the 
Perturbers should be checked, and the Epoch should be set to the value indicated above.  If any of these 
are not the case, your orbit will be incorrect.  Go back and try again! 
 

5. What was the RMS error before you included these two observations?  What was it after?  
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The parameters that describe the orbit are listed in the “Orbital elements” box, but they have also been 
saved in a pair of text files.  You’ll want to save these for later, so please open up the Find_Orb folder in 
the “Killer Asteroids Project” directory and locate the files elements.txt & mpc_fmt.txt.  In a new window, 
navigate to your group’s folder and then on to “2007 WD5/Orbit Results/Epoch 1/Data Set A.”  (There 
may also be some dates in parentheses, to help you keep the epochs and data sets straight.)  Drag the two 
files mentioned above from Find_Orb to the “Data Set A” folder.  You will come back to these 
momentarily.  Also, while you have the Find_Orb folder open, please delete the file mpcorb.dat, if it exists.  
(Find_Orb will create all of these files again later when needed.) 
 
You can also use Find_Orb to predict the position of the asteroid at a particular time, based on the currently 
loaded orbit.  When that orbit is the “best guess” based on a given set of observations, this will represent 
our best prediction for that asteroid’s position.  To do this in Find_Orb, you will click the “Ephemeris…” 
button, about halfway down on the right.  (An ephemeris is a table of the expected positions of an 
astronomical object, at regular intervals covering some period of time.  In this case, you will create a 
simple one-line ephemeris for a single moment in time.)  Enter the following values into the text boxes: 
 
 Day:  8.37070   # steps:  1 
 Month:  11   Stepsize: 1s (lower-case matters) 
 Year:  2007 
 Latitude: 645   Longitude:   (leave it blank) 
 
(The number in the Latitude box is actually the Observatory Code for the Sloan Digital Sky Survey telecope 
in New Mexico, for which the latitude and longitude are known.) 
 
Uncheck the boxes for showing Motion Details and Alt/Az, and click the “Go” button.  What you should 
see at the bottom of the window is the asteroid’s predicted position (RA & Dec) as seen by the SDSS 
telescope on the decimal date of 2007 Nov 8.37070, as well as some additional data at the end of the line.  
Click the “Save” button, navigate to “2007 WD5/Orbit Results/Epoch 1/Data Set A” in your group’s folder, 
and save with a filename of prediction.txt.  You’ll use these results later in today’s lab.  Finally, click on 
“Done”. 
 
Find_Orb has another trick up its sleeve:  We may now have a best-guess orbit for the asteroid, but how 
certain are we that it’s accurate?  One way to find out would be to try thousands of possible orbits that fit 
the observations, and see how much they differ.  Let’s do that!  First, click on the Settings button and 
change the “Monte Carlo noise” value to 0.5, then click OK.  Also, check that all of your other settings 
have not changed since you set them above.  Now click the “Monte Carlo” button, and its label will be 
replaced with a series of numbers.  Find_Orb will chug along in the background as you continue working 
on this lab.  Take note of the current time, and remember to come back to collect its output in about 25 
minutes, when the number gets above 3,000. 
 
What’s going on here?  According to Wikipedia, “a Monte Carlo method is a computational algorithm 
that relies on repeated random sampling to compute its results.”  (The randomness and repetitiveness of this 
method made the Manhattan Project scientists of the 1940s think of casino games, so they named it after a 
famous casino in Monaco.)  Find_Orb randomly changes the RA and Dec coordinates of each of the 
observations in the astrometric data file by some small amount (the “Monte Carlo noise” value, which you 
previously set to 0.5 arcseconds).  Each set of freshly altered data produces a new orbit, which is then 
stored in the file mpcorb.dat and the number on the Monte Carlo button increases by 1. 
 
Why are we doing this?  The positions in the astrometric data file are not absolute, but may have some 
uncertainty associated with them.   Calculating thousands of orbits based on these randomly-altered data 
will allow you to estimate the uncertainties in the positions you will predict for the asteroid, based on the 
uncertainties in all of its positions measured to date.  Uncertainties are unavoidable in science, and 
minimizing them is an important part of scientific research. 
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After about 25 minutes, when you’ve generated at least 3,000 alternate orbits, you will click the Monte 
Carlo button (now labeled with the running orbit-count) again to stop the process.  You will also need to 
grab the resulting mpcorb.dat file that was mentioned above.  For further instructions, see Part IV. 
 
 

 
 
 
Now, go back to “2007 WD5/Orbit Results/Epoch 1/Data Set A” in your group’s folder and open the 
elements.txt file, which contains the results of your best-guess orbit for 2007 WD5 based on the available 
observations.    Within that file, locate the following seven orbital parameters.  (You don’t need to write 
them down, you should just learn where to find them in the file.) 
 
 a = mean distance (or semimajor axis)  [AU] 
 e = eccentricity     [unitless] 
 Incl. = inclination (i)     [degrees] 
 Node = (longitude of the) ascending node   [degrees] 
 Peri. = arg(ument) of pericentre/perihelion (w)  [degrees] 
 M = mean anomaly (L)    [degrees] 
 Epoch = arbitrary reference date    [date, or Julian Days] 
 
The seventh and final orbital parameter is the epoch, or the moment in time at which all of the other 
parameters apply.  You will find this listed two different ways in the elements text file: 
 “Epoch 2007 Nov  8.0 TT = JDT 2454412.5” 
For Part III, you will be interested in the part of the Epoch that comes after the “JDT,” which gives the 
“Julian date,” or the number of days elapsed since noon UT on January 1, 4712 BC.  You will be entering 
these parameters into another program shortly, and it is important that you enter all seven values correctly. 
 
 
 
 
Part III:  Working with Asteroids in Starry Night 
 
You will now explore how these seven orbital parameters specify the shape and orientation of the asteroid’s 
orbit, as well as its position along that orbit.  But before you get started using Starry Night, you first need to 
make a few changes to the preferences.  Open “Starry Night Pro Plus 6” from the desktop.  (If it asks about 
checking for updates, click “Cancel.”  If it asks about OpenGL, try “Keep.”)  Then select “File > 
Preferences…” and make the following changes. 
 
 General: 
  Uncheck “Show document save warnings” 

Number Formats: 
  Declination to “dd mm ss” 
  Right Ascension to “hh mm ss” 
 Cursor Tracking (HUD) > Show: 
  Check “Dec (J2000)” 
  Uncheck “Dec (JNow)” 
  Check “Distance from observer” 
  Check “Name” 
  Check “RA (J2000)” 
  Uncheck “RA (JNow)” 
 Startup/Auto Updates: 
  Max number of asteroids read in at startup:  3000 
  Uncheck “Automatically check for updates from StarryNight.com” 

While you’re waiting, please continue with the rest of the lab. 
You won’t need these Monte Carlo results until Lab #2. 
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Close the preferences window by clicking the red “X” in the upper-right corner.  Then, click on the 
“Options” tab near the top of the left edge of the Starry Night window, which will open up a sidebar.  (Note 
that you can widen these sidebars if necessary, and in some cases you can scroll right/left within it.)  Look 
in the section labeled “Stars”, and uncheck the “All-Sky Image” option.  Click the “Options” tab again to 
close it.  These changes should be remembered the next time you use the program, so you should not have 
to repeat these steps next time. 
 
You are about to add your best-guess orbit for 2007 WD5 into Starry Night, but first let’s examine how to 
work with this new function.  Begin by selecting “File > New Asteroid Orbiting Sun…” from the pulldown 
menus.  At the top of the window, change the asteroid’s name from “Untitled” to “2007 WD5”.  At the top-
right, try zooming in and out with the “\/” and “/\” buttons.  Also try clicking and dragging in the orbit 
display window to change your viewpoint.  The three beige-colored orbits shown here are, from smallest to 
largest:  Mercury, Earth, and Jupiter.  (You will need to zoom out to see Jupiter.)  The light-blue orbital 
path is the asteroid you are currently adding. 
 

6. Match each of the 6 parameters on the left below with the description of its effect on the 
asteroid’s orbit on the right.  Your answers should be submitted as a list of matches:  
“Mean Distance = Description X,” “Eccentricity = Description Y,” etc.  Determine the 
matches by playing with each of the 6 orbit-parameter sliders in Starry Night to get a feeling 
for what each one does.  When you get to the last 3 sliders, it will help if the eccentricity is set 
around 0.5 and the inclination is near 45°.   

 
 

Orbit Parameters 
• mean distance 
• eccentricity 
• inclination 
• ascending node 
• argument of perihelion 
• mean anomaly 
 
 
 
 
 
 

Descriptions of Effects 
o Angle between the asteroid’s orbit and the Earth’s orbit 

(jumping rope) 
o Shape of the asteroid’s orbit 

(rubber band) 
o Orientation of the elliptical orbit within its orbital plane 

(hula hoop) 
o Placement of the asteroid along its orbital path 

(car on a track) 
o Size of the asteroid’s orbit 

(shrink or grow) 
o Where the asteroid goes from below Earth’s orbit to above it 

(spinning coin)
 
Now, use the following steps to enter the parameters for 2007 WD5 from your elements.txt file into Starry 
Night.  First enter the epoch (in Julian-date format), which specifies the moment in time at which all of the 
remaining parameters apply.  (Look back at the previous page if you need help finding the epoch value in 
the text file.)  Next, using the sliders again, approximately enter the other 6 parameter-values from the text 
file.  Just get as close as you can on each of them, using only the sliders, and watch what effect each has on 
the orbit.  Change the zoom and the perspective if necessary!  Next, go back through and set them exactly, 
using either the keyboard or copy-and-paste from the elements text file.   
 

7. Do you think that this asteroid could currently be classified as “potentially hazardous” to the 
Earth?  Why or why not?  (We have not defined what it means for an asteroid to be 
“potentially hazardous,” so you will need to think about what that might mean to you.) 

 
8. What criteria do you think an asteroid’s orbit needs to satisfy in order for a collision with the 

Earth to be possible? 
 
You can now close the add-an-asteroid window by clicking on the red “X” in the upper-right corner.  When 
it asks, make sure to save your changes!  
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Now, a little backstory.  On 2007 Dec 21, the asteroid 2007 WD5 made the national news when its 
predicted odds of impact with Mars were upgraded from 1-in-350 (0.3%) to 1-in-75 (1.3%).  You can read 
NASA’s original press release here: 
 http://neo.jpl.nasa.gov/news/news151.html 
In it, they said that “the asteroid is becoming increasingly difficult to observe,” and that they would only be 
able to improve their impact predictions once it “became observable again in early January.”  But what if 
some observatory had already taken a picture of it, but didn’t realize it?  That data could be used to improve 
those predictions immediately, without waiting weeks for more observations.  Fortunately, the Sloan 
Digital Sky Survey (SDSS) telescope did happen to image this asteroid on 2007 Nov 8, as it was searching 
for supernovae in distant galaxies.  What’s amazing about these images is that they were taken 12 days 
before the asteroid had even been officially discovered! 
 
You could now use Starry Night to predict the position of 2007 WD5 in these SDSS images, based on your 
best guess at its orbit.  However, Starry Night is not accurate enough at placing asteroids in the heavens for 
our purposes.  We will use it in the coming weeks when we want to understand the positions of asteroids 
relative to one another, which will be useful in measuring our uncertainties.  But we want to know the 
absolute position of the asteroid, so we’ll just use the Find_Orb results you saved earlier. 
  
Locate the file prediction.txt within “2007 WD5/Orbit Results/Epoch 1/Data Set A” in your group’s folder, 
and open it in a text viewer.  Use it to answer the following questions. 
 

9. What were the asteroid’s predicted RA and Dec?  Also specify the date and time (with 
time zone!) of the prediction. 

 
10. For this date and time, what was the predicted distance between the Earth and the asteroid?  

(This is listed in astronomical units (AU) in the column labeled “Delta”.) 
 

11. If a celestial globe is available in the lab, use it to locate the (RA, Dec) coordinates from your 
answer to Question #8.  In which constellation are these coordinates located? (If you find the 
globe confusing, please go back and re-read the coordinate descriptions on page 2.  Also, 
please be careful when dealing with leading zeros!  Just as on a clock using “military time,” 
00:59:59 is nearly the same as 01:00:00, and is NOT the same as 59:59:00!) 

 
 
 
Part IV:  Cleaning Up After Yourself 
 
As was mentioned previously, you may be sharing your computer with students in another section of this 
class.  To avoid confusion and potential loss of data, please do the following: 
 

• In Starry Night, using the arrow button to the left of its name, please “Delete 2007 WD5.”  (You 
can’t have two asteroids with the same name.)  Then exit Starry Night. 

 
• If the “Find_Orb” program is still running its “Monte Carlo” process, turn it off by clicking the 

button labeled with the running orbit count.  Then click “OK” to turn off the program. 
  
• Move the “mpcorb.dat” file from the “Find_Orb” folder to “Epoch 1/Data Set A” in your group’s 

folder.  You will use it next time.  Do not leave a copy in the “Find_Orb” folder.  The program 
will append to the end of the file if it exists, which can get confusing when there are 100s or 1000s 
of entries. 

 
• Make sure all of the files you have saved are in your own group’s folder within “Killer Asteroids 

Project/Student Data/”. 
 


